GroveStreams

Special characters export479

pat private msg quote post Address this user
Hi,

1) When doing table or graphic dashboards with labels including accents everything looks good but when exporting in csv data the accents are not recognize and gives special characters

2) While exporting in csv the character delimitation is ',' and the decimal is '.'. Would it be possible to have an additional export csv with a ';' delimitation and ',' as a decimal separator

3) In the units of a component, I tried to change the decimal separator using the following :
To reverse the grouping (,) and decimal (.) for international numbers, add /i to the end. For example: 0.000,00/i

I have no success with that one. Using the exact format above (0.000,00/i), I have '26.30000'. Shouldn't I have '26,30' ?

Thank you
Post 1 IP   flag post
MikeMills private msg quote post Address this user
For 3): if you change the format to (0,000.00/i), does that work? I think the formatter assumes the 0,000.00 will be in the US format and then the /i changes things.
Post 2 IP   flag post
pat private msg quote post Address this user
With (0,000.00/i), I have 28.70
Same as without /i
Post 3 IP   flag post
MikeMills private msg quote post Address this user
OK. The /i is supposed to have the number formatter look at your Operating System Localization settings and adjust for that. I tried changing my localization settings to Dutch and it didn't adjust.

Do you have your Operating System localization settings to something that should change the thousands separator and decimal separator?

We could add those separator options to the Unit and do away with the /i option, but I just want to make sure the /i isn't working as our web toolkit documentation says it should.
Post 4 IP   flag post
pat private msg quote post Address this user
I tried different setting in my localization (mac os x) inverting '.' and ',' as for decimal and grouping operator but it doesn't seem to have any effect on the result.

If we have ',' as a decimal separator in the unit, will there be any problem when exporting to excel as ',' is also the field separator ?
Post 5 IP   flag post
MikeMills private msg quote post Address this user
We will add the two separator options to the Unit in the next few days. I'll post here when it's done.

I don't think there will be a problem exporting because some, or all, dashboard widget exporters put the value within quotes.
Post 6 IP   flag post
MikeMills private msg quote post Address this user
This enhancement has been added. Do an F5 to refresh the browser cache and see the changes. We previously utilized an /i at the end of the format, but that technique quit working. We added the separator options to replace the /i option. Any existing /i's will be ignored and not included in the resulting formatted number.

The Number format (i.e. 0,000.00) still requires the comma to represent the thousands separator and the period to represent the decimal separator. Those items will be changed with the separators during the formatting process.


Post 7 IP   flag post
pat private msg quote post Address this user
Great that works for 3) and solves also partly the 2). Thank you.

Please keep me informed for 1) : accents while exporting
Post 8 IP   flag post
MikeMills private msg quote post Address this user
For 1):

Can you tell me what accent character is being exported?
Can you tell me what is being put in the exported csv file (open it in notepad to see what is actually in there).
Post 9 IP   flag post
pat private msg quote post Address this user
The character is é for instance
Below a picture of export in PDF

In text Edit it is ok but in excel it gives something like éééeé



Post 10 IP   flag post
MikeMills private msg quote post Address this user
Can you show what it looks like in NotePad or some other Text editor (the csv file)? I think it is exporting the character as HTML and I'm trying to determine where the character is coming from. For example, is it coming from the Unit or is it an actual text stream value? Seeing a couple of rows from the raw export will tell me.
Post 11 IP   flag post
pat private msg quote post Address this user
In TExtEditor, looks like it is ok.
I have "Arrivée" (this is the name of a stream in a dashboard)
it is when opening in excel that the character is not good.

Same for the units, they are ok in TextEditor but not in Excel
Post 12 IP   flag post
MikeMills private msg quote post Address this user
I think it is the way Excel is treating the file during the import. You'll have to tell Excel what the file format is during the import.

Try something like this:
https://quizandsurveymaster.com/getting-excel-properly-show-accented-characters/
Post 13 IP   flag post
pat private msg quote post Address this user
Yes this did the trick !
Post 14 IP   flag post
MikeMills private msg quote post Address this user
Great!
Post 15 IP   flag post
2715 15 15
Log in or sign up to compose a reply.
destitute