GroveStreams

Issue with "connect gaps"478

JChristensen private msg quote post Address this user
On a line chart, even though "Connect Gaps" is set to false, gaps do not appear on the chart unless Data Point Cycle on the General tab is set to something other than "(none)". Is this working as intended?
Post 1 IP   flag post
MikeMills private msg quote post Address this user
I couldn't reproduce this problem. I tested with an Interval stream. Gaps will only appear in a line chart for Interval streams. Is your stream an Interval stream?
Post 2 IP   flag post
MikeMills private msg quote post Address this user
The system cannot detect gaps for regular streams since their sample times can vary. When Data Point Cycle is selected, an Interval stream is created dynamically from the Regular stream and graphed. That's why gap detection can be detected when a cycle is selected.

A workaround for gap graphing of a regular stream: Select a Data Point Cycle that is similar to your regular stream upload time spans. For example, if your device uploads once an hour, select the Hour cycle for the Data Point Cycle. Now, what happens if there are two samples within the same cycle (i.e. Hour)? GS will combine those two samples according to what the Stream's dynamic rollup method in its definition, or it will use what is set in the graph widget's settings-Data tab-Selected Stream-Statistic.

Hope that helps.
Post 3 IP   flag post
JChristensen private msg quote post Address this user
Thanks, Mike. Makes perfect sense. My stream is just a regular stream, not an interval stream.

Hope all is well at GroveStreams, Happy New Year!
Post 4 IP   flag post
2724 4 4
Log in or sign up to compose a reply.
destitute