GroveStreams

Vertical bar chart covering left-hand axis132

seckford private msg quote post Address this user
I've got a dashboard with a number of bar charts (vertical bars), which are fine until the time period covered by the chart is fully used. Then the earliest bar covers the numerals on the left-hand axis; is there any way to stop the bars overwriting the axis numbers?

Thanks - Will
Post 1 IP   flag post
MikeMills private msg quote post Address this user
We've added a feature this morning to try and address this. Click on the widget settings - Graph tab: Set the Earliest Time Padding.

This setting is a setting that exists on our underlying charting package. The setting is known to be ignored sometimes.

The Navigator has to be hidden for it to work. The number is a percentage of the total pixels being shown. I had to slowly increase and decrease it from 0.04 to get it to work. Too large of a number or too small of a number and it won't be applied.

Don't forget to Reload your browser while in the GS studio to pickup the latest changes.
Post 2 IP   flag post
MikeMills private msg quote post Address this user
I played with these new setting some more. It is very difficult to get them to work. It seems like the more points being graphed the smaller the padding needs to be. And I couldn't get it to work above viewing 50 points.
Post 3 IP   flag post
seckford private msg quote post Address this user
It looks like I'm on the edge, then, or over it. The line graph has 48 hours at 6 minute intervals, and the bar graph 24 hours at two bars per hour. I tinkered around with both line and bar charts, and couldn't get a result.

Another approach might be to change the color of the axis numerals to black, which would show through any plot lines, but that isn't at present an option.

(BTW the scroll tab on the Earliest Time scroll box just jumps between 0 and 1.)

Thanks for the advice; the dashboard widgets really are very convenient to set up and use.

Will
Post 4 IP   flag post
MikeMills private msg quote post Address this user
Th values are the fraction of pixels to pad so it needs to be between 0 and 1. They don't seem to work well when there are more than 30 points showing.

I had to start with a value of 0.04 and increase/decrease it by .005 to see if I could get a result. I think those settings are pretty much useless and may pull them out. We'll investigate other solutions including changing the label colors.
Post 5 IP   flag post
2837 5 5
Log in or sign up to compose a reply.
destitute