GroveStreams
TravCam private msg quote post Address this user
Trying to get an AEON energy monitor working on Grovestreams.

I copied over the code to my HUB and put the API in.

Best I can tell, it's authenticating the API (or I wouldn't be able to see these errors in GS)

From what I have read both here and on ST, the components will auto populate. That isn't happening.

Any help is appreciated!


When I run an API trace, I get this:
API Exception: Access Denied for API Key

API Exception Details:



Resource Path:
/api/feed
Resource Method:
PUT
Client Address:
54.82.4.129
Client Attributes:
{org.restlet.startTime=1544445286893, org.restlet.http.headers=[[accept: */*], [content-length: 0], [host: grovestreams.com], [connection: Keep-Alive], [user-agent: Apache-HttpClient/4.5.2 (Java/1.7.0_181)], [Accept-Encoding: gzip,deflate]], org.restlet.http.version=1.1}


Exception:
Access Denied for API Key

Call Stack:
com.-gs-.-lab-.utility.Validator.throwErr(Validator.java:9)
com.-gs-.-lab-.storage.OrgApiKeyStore.checkRights(OrgApiKeyStore.java:422)
com.-gs-.-lab-.security.AccessRights.checkRights(AccessRights.java:95)
com.-gs-.-lab-.security.AccessRights.checkRights(AccessRights.java:44)
com.-gs-.-lab-.converters.UFeedConverter.attemptCreateByTemplate(UFeedConverter.java:912)
com.-gs-.-lab-.converters.UFeedConverter.extractCompUids(UFeedConverter.java:561)
com.-gs-.-lab-.converters.UFeedConverter.fromJson(UFeedConverter.java:336)
com.-gs-.-lab-client.client.FeedResource.doPutJson(FeedResource.java:366)




You are allowed one API exception notification per hour per authenticated session. This was the latest exception for this hour.
Post 1 IP   flag post
MikeMills private msg quote post Address this user
Looks like your API Key doesn't have rights to allow for an API Feed PUT.

Look at the ST tutorial part that describes which API key to use and make sure you followed that part correctly.
Post 2 IP   flag post
TravCam private msg quote post Address this user
Actually, my issue began on organization setup... I didn't have those API options because I apparently selected No Blueprint in advanced tab. Deleted my org and followed defaults and then the proper API options materialized... Thanks!
Post 3 IP   flag post
2839 3 3
Log in or sign up to compose a reply.
destitute