GroveStreams

Organization Backup - How to Test545

Essential_WD private msg quote post Address this user
I have a Windows Service application that uses the API to fetch a backup of each organization. My application succeeds in downloading a non-empty ZIP file for each organization. However, several organization's System Notifications, I get several "Organization Backup Failed" alerts. This occurs despite my application's success in fetching the backup files without error. Because of this error,
I would like to test whether the backup file can actually be used to backup an organization. How could I test this, without actually overwriting an organization's data?
Post 1 IP   flag post
MikeMills private msg quote post Address this user
Create a new organization and don't select a template while creating it.

Then enter the new organization and select Admin/Backup-Restore/Restore Organization. Select your backup zip file.

My guess is the backup failed and the zip file is missing entities and the internal JSON is corrupt and will not restore.

Large organizations can take a long time to backup. If backing up to a local file and your network cuts out for a bit, the backup will fail.

Most pricing plans allow for file storage in an organization (just not the Free one). You could try to backup the org to a component stream file. Then download that file. This procedure requires less network time.

Another thing to try, if it is a large organization, is to backup selected folders at a time.
Post 2 IP   flag post
Essential_WD private msg quote post Address this user
Thank you for the response!
We ended up testing the backup packages and they succeeded when we kept the default blueprint selected on the new org we restored over. Oddly enough, they all succeeded, even the ones that had the "failed" notifications (the restores did fail if I chose no blueprint).
I was informed that the time we performed the backups was a particularly busy one for our network, so I changed the time the backups occurred. No failed notifications have occurred since the switch.
Thank you again for your help!
Post 3 IP   flag post
2973 3 3
Log in or sign up to compose a reply.