GroveStreams

Reauthenticate user when changing ownership90

bioagbob private msg quote post Address this user
I was messing with the Owner settings on one of my organizations. I gave ownership to another account. When I tried to change the Owner back to my account, a "Reauthenticate logged in user" box popped up asking for my login password. When submitted, the popup box remains with the password field underlined in red (no error message). I tried several times. If I click cancel, it logs me out of GS. This appears to be a bug. (If I enter the wrong password is says "Invalid credentials".) I realized that since I'm not Owner, it probably needed the credentials of the new owner. I tried that and it just logs me in to that account.

I realize that there might not be a good way to TAKE ownership from another account (even if given away originally). So perhaps the pop up box should just say something like "only the organization owner can change ownership".
Post 1 IP   flag post
MikeMills private msg quote post Address this user
Thanks for reporting this. We'll take a look at it.
Post 2 IP   flag post
MikeMills private msg quote post Address this user
We've cleaned this up a bit. Only the org owner can assign ownership to another user. It's always been this way, but our UI didn't handle it well.

We now warn the owner about this when they're about to change ownership. If you are no longer the owner, the Is Owner checkbox is hidden so that you can no longer change ownership.

Thanks for reporting this!
Post 3 IP   flag post
2837 3 3
Log in or sign up to compose a reply.
destitute